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Notes on the teaching data set for British Social Attitudes 2004 (UK Data Services SN 6096,) 

 
As used in Marsh  & Elliott, "Exploring Data" (2008)  
    
John Hall        (Draft only: 11 Feb 2014) 

 
SPSS saved file bsa2004_teach.sav is a subset of 49 variables from the main survey.  It is one of 
five data sets used in the book and you need to be a registered user to access it.  However, you do 
not need the actual file to be able to follow and understand these notes. 
 
Extract from userguide: 
 

Exploring Data 2nd edition: The Teaching Datasets 
 
The five datasets documented here contain much more information than was used in the text or the 

exercises of the second edition of ‘Exploring Data’. It is hoped that they will provide interesting 

material for you to explore using the SPSS package. The data has been taken from several different 

sources and all the datasets are available in machine-readable form for teaching purposes from the 

ESRC Data Archive at the University of Essex. Brief documentation about the variables in each dataset 

is provided here but fuller information about the studies from which the data has been extracted are 

given in the chapter in which the dataset is first used and on the website for the book 

http://polity.co.uk/exploringdata . Readers are referred to the original sources for the complete 

documentation of the data. 

 

Many of the datasets that are available to researchers from the ESRC Data Archive contain literally 

hundreds, and sometimes thousands, of variables. This can make them unwieldy and daunting for 

students and junior researchers to use. The datasets documented here have therefore been specifically 

designed for students in that they include only a small subset of the original variables. However there 

has been no sub-setting of the total number of cases in the datasets so the results obtained from 

analysing them will be the same as results obtained when analysing the full datasets available from the 

archive. 

 
 

http://discover.ukdataservice.ac.uk/catalogue/?sn=6096&type=Data%20catalogue
http://surveyresearch.weebly.com/marsh-and-elliott-2008.html
http://www.esds.ac.uk/doc/6096/mrdoc/pdf/6096userguide.pdf
http://polity.co.uk/exploringdata
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Data from the British Social Attitudes survey are only used in chapter 12 and then only for 
modelling.  There is only one 3-way tabulation: the rest are proportions for modelling.  The onlu 
tabulations (for YCS11) are in chapter 6 and only produced with GUI, not syntax (p 123 and figs 
6.5, 6.6). 
 
File: bsa2004_teach.sav  (UKDS SN 6096, 77 kb) 
 
On opening (in Variable View): 
 

 
 
Scroll to end, or Ctrl + End: 
 

 
 
There are 49 variables in the file. 
 
Switch to Data View: 
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Scroll to end, or use Ctrl + End: 
 

 
 
There are 3199 cases in the file. 
 
Back to Variable View: 
 

 
 
Scroll back to top, or use Ctrl + Home: 
 

 
 
You can't see the variable or value labels properly, so you need to widen the Label column by 

placing the cursor over the right hand column separator (as with adjusting the page margins in 
Word, a double-headed arrow ←→ will appear when the cursor is correctly placed: to make it 
easier to see I've coloured it red in the figures below ←→): 
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                 ←→  
 
 
 
 
 
 
. . and dragging it to the right until you can see the full label: 
 
 
 
 
                       ←→  
 
 
 
 
 
 
Scroll down the file to find the longest label: if you can't see it in full, widen the column a bit more 
until you can: 
 
 
 
 
                       ←→  
 
 
 
 
 
 
Now do the same for the Values column.  Only the first value label is displayed for each variable, 
enclosed in {      } followed by three dots . . .: 
 
 

 
 
 

 
                             ←→  

 
 
 
 
 
 
 
If you want to see all the labels for a particular variable, click on the three dots, then on the blue 
box: 
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In the Data Editor, scroll down to find the longest value label [for variable qual1] and widen the 
Value column to accommodate the full label: 
 
 
 
 
                         ←→  
 
 
 
 
 
 
The remaining columns have now been pushed out of the Data Editor window, but you don't need 
most of them at this stage.  The only ones that matter for now are the Missing and Measure 
columns.  You don't really need Type, Width or Decimals, so you can move them out of the way 
by dragging them across to the right of the Data Editor.  Highlight all three by holding the left 
mouse button down over Type and dragging it across the the Width and Decimals column 
headings: 
 

 
 
Hold the left mouse button down over any of the headers and drag them across to a position after 
Missing  (a thin red vertical line will indicate the position reached): 
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Now click on Measure: 
 

 
 
Hold the left mouse button down over Measure and drag the column to the left, to a position 
between Name and Label: 

 

 
 
The file is now easier to navigate and use, but you have not finished yet!   
 
You still need to make some initial checks on the file contents, especially the measurement levels 
and missing values.  A quick check on names and labels can be done with: 
 
File > New > Syntax 
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Type in:  
 
 display labels.   [Don't forget the full stop!] 
 

 
 
[NB: the display command is not available via the GUI] 
 
If you use the SPSS prompts, it will look like this: 
 

 
 

Press the green triangle  or Ctrl+R to execute the command:  SPSS displays a long narrow 

table: 

 
 
 ~ ~ ~ ~  
 
  

  
 
. . . which then needs to be widened via Pivot Tables. 
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In the Viewer, double click on the table: 

 

  
 
and drag the right margin out far enough to get the labels on a single line.    
 
Closing the pivot table window . . .    
 

  
 
reformats the table:  
 

 
 
Right click > Copy can then be used to copy the table and paste it into Word with Ctrl + V.  Even 
then the table is double-spaced, so when copied into Word it needs resetting to single space: 
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Variable Position Label 

Serial 1 Serial Number                         Q1 
SPoint 2 Sample point  <167-299>               Q9 
StRegion 3 Standard Region [11 categories] dv   Q11 
Region 4 Region          [6 categories]dv     Q12 
Country 5 Country: England, Scotland or Wales? Q28 
RSex 6 Sex of Respondent                    Q39 
RAge 7 Respondent's age in years            Q40 
PeopTrst 8 People can be trusted/can't be too careful?A2.13 
RNSSEC 9 NS-SEC - long version               Q519 
REconAct 10 Respondent's main economic activity last week? Q539 
Tea 11 Terminal education age<categorised> Q766 
Tea2 12 How old was Respondent when left Full Time Education?Q763 
HEdQual 13 Highest educational qualification obtained   Q829 
HEdQual2 14 Highest educational qualification obtained [postgrad]Q830 
HHincome 15 How much household income last year Q972 
UnionSA 16 Is Respondent a member of a Trade Union/S.A.?Q604 
TUSAEver 17 Has Respondent ever been a member of a TU/SA Q605 
NghBrHd 18 How long Respondent lived in neighbourhood?  Q632 
ResPres 19 Respondent live in city/suburbs or country?  Q697 
Voted01 20 Did Respondent vote 2nd June 2001 in G.E.?   Q834 
PdJobSC 21 Respondent currently in paid work?A2.48B2.22C2.23 
CharOft 22 Respondent give money to charity how often?  B619 
CharAmt 23 Respondent gives how much to charity per yearB620 
PolitSC 24 How interested Respondent in politics?      A2.10 
GovRight 25 Trust people in government to do what is rightA2.11a 
GovSelf 26 Politicians for what get out of itA2.11b 
DemoNow 27 How well GB democracy work today? A2.25a 
GrpMemb1 28 Respondent would/did join a political party?A2.6a 
GrpMemb2 29 Respondent would/did join TU,profession association?A2.6b 
GrpMemb3 30 Respondent would/did join church, religious associationA2.6c 
GrpMemb4 31 Respondent would/did join sports/cultural groupA2.6d 
GrpMemb5 32 Respondent would/did join voluntary associationA2.6e 
IncDiffs 33 Income differences GB to large?A2.39aB2.13a 
IncDiff 34 Government should reduce income differences.?A2.39bB2.13b 
IDCards 35 Every adult should have an ID card? A2.61d 
MoreWelf 36 Government should spend > on poor     A2.63bBC2.44b 
SocHelp 37 People not deserve any help   A2.63dBC2.44d 
DeathApp 38 Death penalty appropriate for some crimesA2.66cB2.47cC2.46c 
WrongLaw 39 Always obey law even when law is wrongA2.66eB2.47eC2.46e 
PartyId2 40 Party political identification (compressed)    dvQ211 
agegp1 41 Age grouped (1) 
agegp2 42 Age grouped (2) 
incomegp 43 Household income last year grouped 
incomeg1 44 Household income last year grouped 
trust 45 Attitudes towards trusting people 
volgp 46 Ever been a member of a voluntary group? 
volgp1 47 Currently a member of a voluntary group? 
qual1 48 Highest level of Qualifications (1) 
qual2 49 Highest level of Qualifications (2) 

Variables in the working file 

 
 
The variables are actually in two groups.  The original variables are serial to wronglaw: the 
variables partyid2 to qual2 are derived.  You can display groups of labels if you specify which 
variables you want. 
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[NB: DISPLAY stays red until you add the full stop] 
 

 
 
. . or you can use abbreviated syntax for  
 
Original variables only: 
 

 
 
Derived variables only 
 

 
 

. . and press the green triangle  or Ctrl+R to execute the command(s): 
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Original variables only: 
Variable Labels 

Variable Position Label 

Serial 1 Serial Number                         Q1 
SPoint 2 Sample point  <167-299>               Q9 
StRegion 3 Standard Region [11 categories] dv   Q11 
Region 4 Region          [6 categories]dv     Q12 
Country 5 Country: England, Scotland or Wales? Q28 
RSex 6 Sex of Respondent                    Q39 
RAge 7 Respondent's age in years            Q40 
PeopTrst 8 People can be trusted/can't be too careful?A2.13 
RNSSEC 9 NS-SEC - long version               Q519 
REconAct 10 Respondent's main economic activity last week? Q539 
Tea 11 Terminal education age<categorised> Q766 
Tea2 12 How old was Respondent when left Full Time Education?Q763 
HEdQual 13 Highest educational qualification obtained   Q829 
HEdQual2 14 Highest educational qualification obtained [postgrad]Q830 
HHincome 15 How much household income last year Q972 
UnionSA 16 Is Respondent a member of a Trade Union/S.A.?Q604 
TUSAEver 17 Has Respondent ever been a member of a TU/SA Q605 
NghBrHd 18 How long Respondent lived in neighbourhood?  Q632 
ResPres 19 Respondent live in city/suburbs or country?  Q697 
Voted01 20 Did Respondent vote 2nd June 2001 in G.E.?   Q834 
PdJobSC 21 Respondent currently in paid work?A2.48B2.22C2.23 
CharOft 22 Respondent give money to charity how often?  B619 
CharAmt 23 Respondent gives how much to charity per yearB620 
PolitSC 24 How interested Respondent in politics?      A2.10 
GovRight 25 Trust people in government to do what is rightA2.11a 
GovSelf 26 Politicians for what get out of itA2.11b 
DemoNow 27 How well GB democracy work today? A2.25a 
GrpMemb1 28 Respondent would/did join a political party?A2.6a 
GrpMemb2 29 Respondent would/did join TU,profession association?A2.6b 
GrpMemb3 30 Respondent would/did join church, religious associationA2.6c 
GrpMemb4 31 Respondent would/did join sports/cultural groupA2.6d 
GrpMemb5 32 Respondent would/did join voluntary associationA2.6e 
IncDiffs 33 Income differences GB to large?A2.39aB2.13a 
IncDiff 34 Government should reduce income differences.?A2.39bB2.13b 
IDCards 35 Every adult should have an ID card? A2.61d 
MoreWelf 36 Government should spend > on poor     A2.63bBC2.44b 
SocHelp 37 People not deserve any help   A2.63dBC2.44d 
DeathApp 38 Death penalty appropriate for some crimesA2.66cB2.47cC2.46c 
WrongLaw 39 Always obey law even when law is wrongA2.66eB2.47eC2.46e 

Variables in the working file 

 

Derived variables only: 
Variable Labels 

Variable Position Label 

PartyId2 40 Party political identification (compressed)    dvQ211 
agegp1 41 Age grouped (1) 
agegp2 42 Age grouped (2) 
incomegp 43 Household income last year grouped 
incomeg1 44 Household income last year grouped 
trust 45 Attitudes towards trusting people 
volgp 46 Ever been a member of a voluntary group? 
volgp1 47 Currently a member of a voluntary group? 
qual1 48 Highest level of Qualifications (1) 
qual2 49 Highest level of Qualifications (2) 

Variables in the working file 
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There's still a bit of tidying up needed. 
 
Go back to Variable View and scroll down to the derived variables on rows 41 to 49: 
 

 
 
If you look at the Decimals column you will see that all these variables have 2 decimal places.  In 

fact they are integers and should have no decimals.  You can check by running frequency counts 
and also by going down the list clicking on the cells in the Values column and then on the blue 
boxes.  A quicker way is to use: 
 
Data > Define Variable Properties (DVP) 
 

 
 
Beginning of file:      End of file: 
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1st problem: The display is set to labels, not names.  You can't see the question numbers.  You 
can stretch the window to see them: 
 

 
 
. . or change the settings to Names with: 
 
Edit > Options 
 

      
 
 

     Click on Apply    

 
 
 
You may get a message: 

Click on OK 

 
 

then OK again 

 
 
DVP now displays names instead of labels:   
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To check the properties of the derived variables, highlight the first one, Partyid2 then Shift click on 
the last one qual2 and click on the blue arrow          to transfer them to the right pane: 
 

   
 

Click on Continue to get the following display:  

 

 
 
If you click on any variable in the left pane all its properties will be displayed.  From this you can 
see that partyid2 has 0 decimals (correct) but that value 8 (= Other/DK/Ref) has not been declared 
as missing (the box is not checked under Missing).  Variables volgp and volgp1 have value -1 (= 
No self-compltn) which has already been declared missing (the box is checked under Missing): 
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For all variables from agegp1 to qual2 the values have 2 decimals, but they are integers resulting 

from a data transformation (RECODE . .  INTO . . ) and need to be changed to 0.  These can be 
changed inside the Data Editor, but there will be no audit trail of what you have done.  You can 

change the properties of any or all variables inside the DVP window: if you do this the Paste button 

(grayed out above) will become active (Paste) and you can use it to save the syntax generated by 

SPSS for any changes made.  For partyid2, if you check the Missing box: 
 

 
 

and click on Paste the following syntax will appear in the active Syntax Editor: 

 

 
 
Using the DVP to change all the decimals from 2 to 0 one by one is time-consuming and produces 
a separate syntax command for each change.   
 

* Define Variable Properties. 
*agegp1. 
FORMATS  agegp1(F8.0). 
*agegp2. 
FORMATS  agegp2(F8.0). 
*incomegp. 
FORMATS  incomegp(F8.0). 
*incomeg1. 
FORMATS  incomeg1(F8.0). 
*trust. 
FORMATS  trust(F8.0). 
*volgp. 
FORMATS  volgp(F8.0). 
*volgp1. 
FORMATS  volgp1(F8.0). 
*qual1. 
FORMATS  qual1(F8.0). 
*qual2. 
FORMATS  qual2(F8.0). 
EXECUTE. 
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An alternative is to use the FORMATS and MISSING VALUES commands: 
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Run > All 
 

  
Now save your work!  [I've been naughty: should have worked on a copy, not the original] 

 
File > Save As 
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The original file is kept, and from now on you are working on your new version. 
 
Final checks: 
 
Data > Define Variable Properties (DVP: 20 variables at a time, except Serial and SPoint) 
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As you work your way down the list you will see that -3, -2 and -1 have (mostly) been declared as 
missing (skipped) but that codes 8, 9, 98 and 99 have not, even though have been labelled as 
Don't know, Refused, Can't choose etc.  Code 97 is also used = Other uncodeable?  You need to 
deal with this before running any analysis.  You may find it easier to work down the list and check 

the Missing boxes where applicable, but you need to use Paste to collect the syntax.  If you click 

OK the changes will be effected, but you will have no syntax and therefore no audit trail. 

 
However there is still a further problem.  SPSS allows up to three discrete missing values, but 
many of the variables in this file actually have more than three values to be treated as missing (eg 
TUSAever has four:  -3, -1, 8 and 9)  SPSS allows two of the specified missing values to be the 
lower and upper limits of a range of values eg (77 thru 99)  One way round this is to recode the 
positive values 8 and 9 to -8 and -9 and specify the missing values as (-9 thru -1). 
 
The safest thing to do is to run frequency counts first, but some variables have many values, so 
don't print them up if you want to save paper. 
 

 
 
You can then work your way through the frequency counts and build up a single missing values 
command for variables with three or fewer missing values and then separate recode and missing 
values commands for the others.  Personally I would recode all the positive missing values to 
negative and just use (-99 thru -1) but this entails changing the value labels to match. 
 
To do this accurately you need to change the settings to print both variable names and labels and 
also values and labels on output. 
 
Edit > Options      Click on Output 
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Change Labels to Names and Labels   in both Outline Labeling and Pivot Table Labeling in the left 

hand side of the window: 
 

  
 

. . then click on Apply, then OK   

 
 
If you scroll down the Measure column, you will see that all variables are Scale: none are specified 
as Nominal or Ordinal.  Again these can  be changed manually inside the Data Editor but there will 

be no audit trail.  It's better to use the DVP and Paste, and even better to write a separate 

VARIABLE LEVEL command.  Some variables appear to be Ordinal, but are only partially 
ordered, so you need to make decisions about whether to treat them as Nominal or recode them 
into ordered categories.  Some variables are binary and can be treated at any level. 
 
The following SPSS program will make the necessary modifications: 
 

title 'Corrections to bsa04_teach_jfh.sav'. 
 
formats agegp1 to qual2 (f3.0). 
 
variable level 
   stregion to rsex reconact unionsa tusaever voted01  
   partyid2 agegp1 pdjobsc incomegp to qual2 
   (nominal) 
   peoptrst rnssec tea tea2 hedqual hedqual2  
   hhincome respres charoft to demonow 
   grpmemb1 to wronglaw agegp2 
   (ordinal) 
   serial spoint rage nghbrhd 
   (scale). 
 
missing values 
   partyid2 hedqual  charoft (8) 
   hedqual2  (9) 
   respres voted01 pdjobsc (8 9)  
   idcards (-1 -2 9) 
   morewelf  (-1 9) 
   unionsa pdjobsc sochelp deathapp wronglaw (-1 8 9) 
   charoft (-2 8 9) 
   rnssec (-1, 98 99) 
   reconact (98 99) 
   tea tea2 (97 98 99) 
   hhincome (97, 98) 
   nghbrhd (98 99) 
   partyid2 (8). 
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recode 
   peoptrst  tusaever charamt politsc govright govself 
   grpmemb1 to grpmemb5 incdiff incdiffs 
   (8=-8)(9=-9) 
   /rnssec  
   (99=-99) 
   /demonow (98 = -98)(99 = -99). 
 
missing values 
    peoptrst  tusaever charamt politsc govright govself 
   grpmemb1 to grpmemb5 incdiffs incdiff rnssec  demonow  
   (-99 thru -1). 
 
add value labels 
  peoptrst  govself  politsc govright 
   grpmemb1 to grpmemb5 incdiffs  incdiff  
    -8 "Can't choose" 
   -9 'Not answered' 
   /tusaever charamt -8 "Don't know" -9 'Not answered' 
     /demonow  
    -98 "Can't choose" 
   -99 'Not answered'. 

 
Finally, there is the problem of the question numbers being at the end of the variable labels.  These 
can be moved to the beginning manually as there are only 49 variables, but the full survey has 
more than 800! 
 
Variable labels were modified for the 2011 survey using a neat piece of Python code supplied to 
my specifications by Jon Peck (Senior Software Engineer, IBM/SPSS) but it needs some minor 
modifications for the 2004 survey as the variable labels are not quite in the same format. 
 
Once I have the data organised to my satisfaction, I plan to produce some tabulations 
demonstrating how to use percentages in contingency tables to illustrate what the models in the 
book are trying to do, a process known as elaboration. 
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Appendix 1 
 
Changing SPSS settings for the Data Editor 
 
You can change the number and order of columns displayed in the Data Editor: 

 

  
 
Click on Edit > Options:   Click on Data > 
 

        
 
Click on      You can move the attributes up or down using the arrows: 
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or uncheck them so they don't display at all:    
 

   Click  to go back to Customise menu: 
 

   Click on  then  to go back to the Data Editor 
 

 
 


