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Block 2:

Nominal and ordinal variables

Analysing one variable

2.1.2.5 Extending your data dictionary

John F Hall

[23 November 2010]

Previous session: 2.1.2.4 Reading in data for nominal and ordinal variables
Exemplar:

British Social Attitudes (1986 survey)

File:

mybsa86_1.sav (British Social Attitudes 1986, 1st saved file)

Task:

1: Add missing values, variable labels and value labels for v541 (Satisfaction with
the way the NHS runs nowadays) and v1510 (Marital status of respondent)
2: Save the contents of the data editor in a *.sav file and the syntax editor in a
*.sps file.

SPSS syntax used1 :
TITLE
MISSING VALUES
VARIABLE LABELS
VALUE LABELS
Open your folder mybsa:
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General formats:
TITLE

' <Any text> ' .

MISSING VALUES

<variable list> ( <value list> )
/ <variable list> ( <value list> )
/~~~~ .

[See 1.4.3 for more details]

VARIABLE LABELS

<variable name1> ' <variable label1> '
/ <variable name2> ' <variable label2> '
/~~~~ .

VALUE LABELS

< variable name(s) > <value1> ' <label1> '
<value2> ' <label2> '
~~~~
/ < variable name(s) > <value1> ' <label1> '
~~~~ .

. . . and double-click on mybsa86_1.sav (the one with the red check design) you saved in the
previous session.
[If you don't already have folder mybsa86 or file mybsa86_1.sav go back to the Block 2 menu
and do the exercises in 2.1.2.3 and 2.1.2.4.]
SPSS automatically generates the following syntax and displays it in the output file.
GET
FILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa86_1.sav'.
DATASET NAME DataSet1 WINDOW=FRONT.

. . . and the data editor will open in whichever view it was last used.

Data View

Variable View
Check that your variables v541 and v1510 have been defined and that the data are present (ie
both views should tally with the screenshots above):
In Variable View click on File > New > Syntax
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. . . to open a new syntax editor:

Before reading on, try writing out the syntax in the space below for TITLE, MISSING
VALUES, VARIABLE LABELS, and VARIABLE LABELS.
Don't forget the primes, slashes and full stops!

TITLE

_______________________________________________________ .

MISSING VALUES

_______________________________________________________ .

VARIABLE LABELS _______________________________________________________
_______________________________________________________ .

VALUE LABELS

_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________
_______________________________________________________ .
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Now let's continue building our file by extending the data dictionary.
1:

TITLE2

Again, good practice is to give your job a title.
title 'Add missing values, variable labels and value labels' .

Click on the
green ►
The output will display:
GET
FILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa86_1.sav'.
DATASET NAME DataSet1 WINDOW=FRONT.
title 'Add missing values, variable labels and value labels' .

2:

MISSING VALUES3

Your syntax for MISSING VALUES should look like this (values 8 and 9 are missing for both):
missing values v541 v1510 (8,9) .
Type this command on the next line. (Start in column 1 and don't forget the full stop):
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General format:
TITLE '<Any text you like>' .

3

MISSING VALUES

<variable list>
( <value list> )
/ <variable list> ( <value list> )
/ ...

where <value list> can be:
(i) up to three numeric or alphanumeric values separated by commas or blank spaces
(ii) for numeric values only, a range of the form:
<value> THRU <value>
LOWEST THRU <value>
<value> THRU HIGHEST
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If you have made errors, part or all of the command will be displayed in red. Once you are happy
with the syntax click on the green ► to run the job.
The output will display your syntax so far:
GET
FILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa86_1.sav'.
DATASET NAME DataSet1 WINDOW=FRONT.
title 'Add missing values, variable labels and value labels' .
missing values v541 v1510 (8,9) .

. . . and the values 8 and 9 will appear in the Missing column in the data editor:

Variable View after missing values added
3:

VARIABLE LABELS4

Your syntax for VARIABLE LABELS should look something like this :
variable labels
v541 'Q.58 Satisfaction with running of NHS'
/v1510 'Q113.b marital status of respondent' .
Type this command carefully into the syntax editor, making sure you put in the primes
(apostrophes) and the full stop (period).
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General format:
VARIABLE LABELS

<variable name> ' <variable label> '
/ <variable name> ' <variable label> '
/~~~~

Example:
variable labels

sex 'Q98a Sex of respondent'
/ v759 'Q96a Should homosexuals teach in school?' .
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If you have made errors, part or all of the command will be displayed in red. Once you are happy
with the syntax click on the green ► to run the job.
The output will display your syntax so far:
GET
FILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa86_1.sav'.
DATASET NAME DataSet1 WINDOW=FRONT.
title 'Add missing values, variable labels and value labels' .
missing values v541 v1510 (8,9) .
variable labels
v541 'Q.58 Satisfaction with running of NHS'
/v1510 'Q113.b marital status of respondent' .

. . . and the Labels column in the data editor will have filled up with your own labels.

Variable View after variable labels added
[The labels are masked, but we can deal with that after the next step.]
4:

VALUE LABELS5

Your syntax for VALUE LABELS should look something like this:
value labels
v541 1 'Very satisfied'
2 'Quite satisfied'
3 'Neither satisfied nor dissatisfied'
4 'Quite dissatisfied'
5 'Very dissatisfied'
/v1510 1 'Married'
2 'Living as married'
3 'Separated or divorced'
4 'Widowed'
5 'Not married' .
Type this command very carefully into the syntax editor paying particular attention to the primes
(apostrophes) and the full stop (period) at the end .
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General format:
VALUE LABELS < variable name(s) > <value1> ' <label> '
<value2> ' <label> '
~~~~
/ < variable name(s) > <value1> ' <label> '
~~~~
Example:
value labels
sex 1 'Men' 2 'Women'
/v1374 to v1379 v1470 v1509 to v1510 1 'Yes' 2 'No' .
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If you have made errors, part or all of the command will be displayed in red. Once you are happy
with the syntax click on the green ► to run the job.
The output will display your syntax so far:
GET
FILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa86_1.sav'.
DATASET NAME DataSet1 WINDOW=FRONT.
title 'Add missing values, variable labels and value labels' .
missing values v541 v1510 (8,9) .
variable labels
v541 'Q.58 Satisfaction with running of NHS'
/v1510 'Q113.b marital status of respondent'
value labels
v541 1 'Very satisfied'
2 'Quite satisfied'
3 'Neither satisfied nor dissatisfied'
4 'Quite dissatisfied'
5 'Very dissatisfied'
/v1510 1 'Married'
2 'Living as married'
3 'Separated or divorced'
4 'Widowed'
5 'Not married' .

.

. . . and the Values column will have filled up in a slightly different way:

Variable View after value labels added
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The labels are again masked, but you can slide the column separators sideways to reveal them
and adjust the other columns at the same time. This makes it easier to see everything.

Unfortunately, this adjusted display cannot be saved and the data editor will revert to the default
after you close it or leave SPSS. If you want see the value labels for a variable, you can click on
the appropriate cell in the Values column, so for v541 (Satisfaction-dissatisfaction with the
running of the NHS)

. . . and then click on the blue square ... to reveal the labels:

You can add, delete or edit the labels inside this box, but hopefully you got them correct in the
syntax before you ran it!
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For v1510 (Marital status of respondent) click on the cell:

. . . then click on the blue square ...

There's a bit more tidying up to do because v541 has been classified as Nominal,but you can
change it to Ordinal by clicking on the cell:

and choosing Ordinal

We have now finished building the first edition of the basic file, complete with all data and basic
data dictionary.
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Before we go any further, good file management practice is to save the data editor again.
Since the data editor originally opened file mybsa86_1.sav from folder mybsa, one method (not
advised here) would be to click on the save icon in the toolbar. This would update the existing
saved file mybsa86_1.sav and the data editor would remain on your screen.
The title in the data editor would change from *Untitled... to mybsa86_1.sav [Data set 1]

However, my preference is not to overwrite the original saved file, but to save the current data
editor in a new saved file with different (incremental) name. With a small data set like this it
doesn't matter so much, but with larger data sets it's good practice to build up files in stages. It's
preferable therefore to save the current data editor as mybsa86_2.sav and the syntax editor as
mybsa86_2.sps. This way you can keep track of your work and there's always the previous
version of the file to fall back on.
Click on File > Save As ...

Navigate to your mybsa folder where file mybsa86_1 was saved last time:
. . . and change mybsa86_1.sav to mybsa86_2.sav in the File name: box
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Make sure PASW Statistics (*.sav) is displayed in the Save as type: box and click on Save
SPSS automatically generates the following syntax and displays it in the output file.
SAVE OUTFILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa86_2.sav'
/COMPRESSED.

The data editor name will change to mybsa86_2.sav

and folder mybsa will now have both editions of the saved file.

Now go back to the syntax editor and click on File > Save As ...
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As before, files of the same type are displayed, in this case mybsa86_1.sps. Change Syntax1 to
mybsa86_2 in the File name: box [other previously used filenames may appear] . . .

Make sure Syntax (*.sps) is displayed in the Save as type: box and click on Save

If you wanted, you could have typed in all the syntax:

. . . and run everything in one pass with Run > All
You could also have typed the missing values and variable labels directly into the appropriate
cells in the data editor, but value labels are more complicated (and tedious) to enter this way.
You could also use the menus, but that's even more tedious. If you don't believe me, try it and
you'll see why!

12

Go back to folder mybsa and open mybsa86_1.sav.

Click on Data > Define Variable Properties

Highlight both variables and click on the blue arrow to drag them across and click on Continue:

.
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Information is displayed for the first variable v541:

Click on v1510 to get:

At least you get a quick count of the number of cases in each category and a quick check on the
values present for each variable!
End of session:
Next session: 2.1.2.6 Checking your file contents
[Back to Block 2 menu]
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