Survey Analysis Workshop 



Copyright © 2010    John F Hall

Block 2:
Analysing one variable


Nominal and ordinal variables
2.1.2.10  Specimen answer for homework exercise 1 

[24 November 2010]
Exemplar:
British Social Attitudes  (1989 survey)
Research questions:  

What is the distribution of marital status of the respondent?   (Q.900a)



What is the distribution of satisfaction-dissatisfaction with the way the 

National Health Service runs?   (Q.58)




 
File:
   
bsa89.txt 
(raw data from the 1989 British Social Attitudes survey)

Homework exercise 1:    Create an SPSS saved file containing the correct data for the above two questions from the 1989 British Social Attitudes survey, together with an appropriate data dictionary.  (See exercises 2.1.2.3 to 2.1.2.6 on the 1986 survey).  

Marital status is asked at Q.900a)





[nominal]
[image: image1.emf]
Satisfaction with "the way NHS runs nowadays" is at Q.72



[ordinal]

[image: image2.emf]
Go to your folder mybsa and double click on folder mybsa89
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 [If you don't have folders mybsa or mybsa89, go back to the Block 2 menu, do the housekeeping in 2.1.2.8 and then exercise 2.1.2.9]  
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The full pathname for the raw data file (after downloading the file and saving it to mybsa89) is:

'C:\Documents and Settings\Owner\Desktop\mybsa\mybsa89\bsa89.txt'

There are 23 records per case.  All codes are numeric integer.  The data are stored as follows:

Satisfaction with the way NHS runs
(Q.72; record 7 column 51)

Marital status 



(Q900a; record 14, column 8)

According to the Technical Report
 missing values have been coded as follows:

Satisfaction with the way NHS runs
8   Don't know       9   No answer

Marital status       
 

8   Don't know       9   No answer

Again, it helps to prepare a table with your questions, variable names, data locations and values to be treated as missing:  the question number and text can also be used later as variable labels:


Question
      
Variable
Record    
   Start          End 
Missing




              name 
number    
 column     column
  values

Q.58      Satisfaction with 

  the way NHS runs
     v751
     7

     41

41
    8, 9

Q.113b  Marital status of 

  respondent
     
   v1408
   14

     10
  
10
    8, 9

Exercise 1:    

Even though we are only working with two variables, we are going to follow good (professional) practice in file-building and work through this exercise in four steps, saving our work at each step.

Step 1:
DATA LIST 
Step 2:
MISSING VALUES, 

Step 3:
VARIABLE LABELS 

Step 4:
VALUE LABELS
To remind ourselves (and anyone else who reads our syntax files) what it is we think we are doing, we shall also annotate our syntax using TITLE, SUBTITLE, and COMMENT
Call up SPSS by clicking on the [image: image5.emf] icon, or however your local system works: 
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Screenshot after launching SPSS 


Opening screen for PASW18



[NB:  I have changed my SPSS settings at launch to open a blank syntax editor as well as a blank data editor: this saves having to use File  > New > Syntax  to open a new SPSS syntax editor every time I launch SPSS.  From the data editor click on Edit > Options.  A screen appears with the General tab open: check the Open syntax window at startup box to open a blank syntax file.  I also like to have more than one data editor open at a time: if you want to dpo the same (and if your version allows it) uncheck the Open only one data set at a time box and click on the   Apply  button to save the new settings.]
Click on the Cancel button (bottom right) to display the blank Data Editor (behind this pane). 
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Make sure you are in  Variable View   (this one has been adjusted by shrinking it to three rows)
Click on File   > New > Syntax  
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. . . to open a blank SPSS syntax editor:
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Step 1:  Give your job a TITLE :


[limit of 60 printing characters]
title ' Homework for nominal and ordinal variables (BSA 1989) ' .
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We are going to build up our data editor one step at a time and save it after each step.  To help us keep track of our work we shall annotate the syntax by inserting a SUBTITLE
 before each command and a COMMENT
 after each step reminding us to save the data editor.
Write a SUBTITLE for the first step:

subtitle 'Step 1:  Define variables and specify data locations' .
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Now write the DATA LIST command specifying the pathname of the external raw data file, the number of records per case, and specifying the names and data locations of your two variables:

data list 



file 'C:\Documents and Settings\Owner\Desktop\mybsa\mybsa89\bsa89.txt'

records 23


/ 7  v751 51

/14 v1408 8 .
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Click on Run  > All     
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. .  . to produce the following output:
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title ' Homework for nominal and ordinal variables (SSA 1989) ' .

Homework for nominal and ordinal variables (BSA 1989)

subtitle 'Step 1: Define variables and specify data locations' .

Homework for nominal and ordinal variables (BSA 1989)
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The data editor header changes from *Untitled1  to *Untitled2 
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Switch to Data View  
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There are no actual data in the file, but your two variable names v751 and v1408 now appear in the first two column headers.  Go back to the syntax editor and type in an EXECUTE command.

execute .

This will cause SPSS to load the raw data into the data editor.
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Click on the green ► .   The command is repeated in the output, but you need to go back to the data editor to see what has happened.  The data editor in Data View   has now filled up: 
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Scroll down to the end of the file (it's quicker to press [CTRL] + [end] ):
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There are 3025 cases in the file.  Go back to Variable View  
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The Measure column has changed from "Unknown" to "Nominal" for both variables, but v751 is actually ordinal, so we need to change it.  Click on the Nominal cell for v751:
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. . . and click on Ordinal :
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At this stage, even though in this exercise you are only creating two variables, it is good practice to save your work.  
Inexperienced (and even experienced) users sometimes try to write, and then execute, their entire set of data definition and dictionary commands before saving their files, but then run into difficulties if there are errors that they cannot later easily trace.
Even with small data sets, you should build up your SPSS saved and syntax files in stages, saving them immediately after executing the DATA LIST command, and again after each of the other basic stages (MISSING VALUES, VARIABLE LABELS and VALUE LABELS).  For large data sets this usually involves writing a series of syntax files, one (or sometimes more) for each stage, which you could call file1.sps, file2.sps etc. to create file1.sav, file2.sav etc. before running checks with utilities such as  DISPLAY LABELS and LIST / CASES n.  
For this exercise we're going to write all the syntax in the same file, but save the data editor at each stage, just as we would if we were creating a *.sav file for all the variables in the entire raw data set.  This may look cumbersome and tedious, but believe me, I've used SPSS since 1972 to process hundreds of survey data sets and this method not only saves both time and tears, but also minimises errors and is easier for beginners and clients to understand .
Add a COMMENT to remind yourself and others (tutors, colleagues or supervisors) what you are supposed to be doing:

comment 'Save the data editor' .
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To save the first stage of your work, go back to the data editor:
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Click on File > Save As ... 
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Navigate to folder mybsa89:



.  . write mybsa89_1 in the File name box:
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. . . and click on Save
The data editor name will change from *Untitled2  to mybsa89_1.sav
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. . and the output viewer will display the automatically generated syntax:

SAVE OUTFILE='C:\Documents and Settings\Owner\Desktop\mybsa\mybsa89\mbsa89_1.sav'

  /COMPRESSED.

Your folder mybsa89 will now contain the SPSS saved file mybsa89_1.sav:
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We also need to save the syntax editor.
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Click on File > Save As ... 
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Navigate to folder mybsa89:



.  . write mybsa89_1 in the File name box:
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. . . and click on Save
The syntax editor name will change from *Syntax1  to mybsa89_1.sps
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. . . and folder mybsa89 will now contain the first edition of the syntax file
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So far, so good.  Now let's start building up the data dictionary.

Step 2:  Add a SUBTITLE describing the next step and a MISSING VALUES command to specify values to be treated as missing:

subtitle 'Step 2: Specify missing values' .

missing values 


v751 v1408 (8,9) .
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Place the cursor in the subtitle line and click on Run > To End
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The command is repeated in the output:
missing values

v751 v1408 (8,9) .

[NB:  Don't worry about the lack of indentation in this and following syntax repeats in the output file: there aren't any warning or error messages and SPSS has already parsed the syntax anyway, using the commas, slashes etc. in your syntax as delimiters.]

The Missing column in the data editor will now contain the values 8 and 9 for both variables:
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Put a comment in the syntax editor as a reminder:

comment 'Save the data editor again' .
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Save the data editor again by clicking on the blue document icon (2nd in from the left):
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The icon will now be grayed out:
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Step 3:  Add a SUBTITLE explaining the next step, followed by a VARIABLE LABELS command with meaningful and helpful labels (keep them reasonably short!):

subtitle 'Step 3: Specify variable labels' .

variable labels


 v751    'Q.58: Satisfaction with the way the NHS runs ' 


/v1408  'Q.113b: Marital status of respondent' .
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Place the cursor in the subtitle line and click on Run > To End
[image: image44.png]*mybsaB9_1.5ps - PASW Statistics Syntax Editor.

VIS 1VIEUs (6.9] ‘Step Through
comment ‘Save the data editor | @ contnue  SniteTab

Active DataSet

P subtitle Step 3: Specify vari

variable labels

I V751 "Q.58: Satisfaction with the way the NHS runs *
1408 "Q.113b: Marital status of respondent’

[PASH Statscs Processor s ready| | Transfomatons pendng i 15 Coi2| |01 |




The subtitle and command are repeated in the output and the Label column in the data editor has now filled up:
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You can't see the labels properly, so slide the column separator between Label and Values to the right:
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Save the data editor again by clicking on the blue document icon (2nd in from the left) and add a comment to the syntax editor:

comment 'Save the data editor again' .
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Step 4:  Finally, add a SUBTITLE explaining the final step, followed by a VALUE LABELS command with appropriate and meaningful labels (keep them as short as possible!):

subtitle 'Step 4: specify value labels' .

value labels


 v751
1 'Very satisfied'



2 'Quite satisfied'



3 'Neither'



4 'Quite dissatisfied'



5 'Very dissatisfied' 


/v1408
1 'Married'



2 'Living as married'



3 'Separated or divorced'



4 'Widowed'



5 'Not married' .
[image: image48.png]Transform _ Anayze Graphs Utites Addons Run Tooks Window Help

ﬁHE:ﬂ.l“” LA R PO BRH» H
QYBE U -

21 subtitle ‘Step 4: specify value labels’

22 [value labels

5 Eal 1 Very satisfied

24 2'Quite satisfied”
missing values 25 3 Neither’
 comment 6 4 Quite dissatisfied”
subte: 27 5 Very dissatisfied
variable labels £l N1408 1 'Married
comment 23 2'Liing as married
subite Eil 3"Separated or divorced
vale labels 31 4 Widowed"

2 5 Not married”

[PasH Statsics Processor s ready | | |33 Col0| Ui |




Check to see if the syntax looks OK (ie no red bits indicating grammatical errors or incomplete commands, usually caused by missing primes, slashes or stops).  Place the cursor in the subtitle line and click on Run > To End
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value labels

 v751 1 'Very satisfied'

2 'Quite satisfied'

3 'Neither'

4 'Quite dissatisfied'

5 'Very dissatisfied'

/v1408 1 'Married'

2 'Living as married'

3 'Separated or divorced'

4 'Widowed'

5 'Not married' .

Go back to Variable View   and adjust the column separators so you can see the labels: 
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We've almost finished.  We need to save the data editor one last time by clicking on the icon:
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.  . and add a comment to the syntax editor reminding you to save the file.

comment 'Save the data editor again' .

. . . then save the syntax editor as well  (You should know how to do this by now.)
If you struggled to do this exercise, even after using the crib, go back and do it again, and again (and also the earlier exercises until you are confident with managing files in Windows and using basic syntax in SPSS).  
Practice makes perfect and you need to be able to open, write, execute and save files almost as second nature, otherwise you will always have problems with the mechanics and never get to grips with the logic and theory underpinning the analyses you will be doing later.

End of session

Next session:
  2.1.2.11  Homework exercise 1 - Checking your file
[Back to Block 2 menu]
�    Lindsay Brook, Bridget Taylor and Gillian Prior,  British Social Attitudes 1989 Survey: Technical report 


     (Social and Community Plannning Research, November 1990)


�    SUBTITLE  ' < Any text  > ' .


�    COMMENT  ' < Any text  > ' .	or use an asterisk instead of  COMMENT  eg  	*  ' < Any text  > ' .
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